Enrutamiento entre VLAN con Router (Capa 3)

Diagrama de topología:

Enrutamiento entre VLAN

Enrutamiento entre VLAN

En si el objetivo de este ejercicio es que una VLAN 10 se comunique como una VLAN 20, a diferencia de la comunicación normal en la que se comunica una VLAN 10 con otra VLAN 10, para este propósito se utiliza un router (Capa 3) también se puede utlizar un switch de capa 3.

A continuación la tabla de enrutamiento.

Dispositivo de nombre de host Interfaz Dirección IP Mask de red Gateway
S1 VLAN 99 192.168.99.11 255.255.255.0 192.168.99.1
S2 VLAN 99 192.168.99.12 255.255.255.0 192.168.99.1
S3 VLAN 99 192.168.99.13 255.255.255.0 192.168.99.1
R1 Fa 0/1 192.168.50.1 255.255.255.0 no aplicable
R1 Fa 0/0 Ver la configuración de la subinterfaz no aplicable
PC1 NIC 192.168.10.21 255.255.255.0 192.168.10.1
PC2 NIC 192.168.20.22 255.255.255.0 192.168.20.1
PC3 NIC 192.168.30.23 255.255.255.0 192.168.30.1
SERVIDOR NIC 192.168.50.254 255.255.255.0 192.168.50.1

Asignaciones de puerto de switch.

Puertos Asignación Red
Fa0/1-0/4 Enlaces troncales 802.1q (LAN 99 native) 192.168.99.0/24
Fa0/5-0/10 VLAN 30:Sala 192.168.30.0/24
Fa0/11-0/17 VLAN 10: RyD 192.168.10.0/24
Fa0/18-0/24 VLAN 20: Ingeniería 192.168.20.0/24

Tabla de configuración de subinterfaz: Router 1

Puertos Asignación Red
Fa0/0.1 VLAN 1 192.168.1.1
Fa0/0.10 VLAN 10 192.168.10.1
Fa0/0.20 VLAN 20 192.168.20.1
Fa0/0.30 VLAN 30 192.168.30.1
Fa0/0.99 Vlan 99 192.168.99.1

Bueno lo que hay que hacer primero es deshabilitar todos los puertos usados con el comando shutdown en esta caso de los switch S1, S2, S3 (se utilizo los switch 2960).

s1(config)# int range fa0/1-24
s1(config-if-range)# shutdown
s1(config-if-range)#int range gi1/1-2
s1(config-if-range)#shutdown
s1(config-if-range)#end
Está configuración aplica a los tres switch

Se habilita los puertos (fa0/6, fa0/11, fa0/18) y se pone en modo de acceso al Switch 2

s2(config)# int range fa0/6, fa0/11, fa0/18
s2(config-if-range)#switchport mode access
s2(config-if-range)# no shutdown
s2(config-if-range)# end

Se configura el VTP en los switch donde S1 sera el VTP servidor y expandira las VLAN hacia los clientes(switch en modo cliente).

Nombre del switch Modo de operación del VTP Dominio del VTP Contraseña de VTP
S1 Servidor Lab6 cisco
S2 Cliente Lab6 cisco
S3 Cliente Lab6 cisco

A continuación se muestra la configuración.
Conf para S1

S1(config)#vtp mode server
S1(config)#vtp domain Lab6
S1(config)#vtp password cisco

Conf para S2

S2(config)#vtp mode client
S2(config)#vtp domain Lab6
S2(config)#vtp password cisco

conf para s3

S3(config)#vtp mode client
S3(config)#vtp domain Lab6
S3(config)#vtp password cisco

A continuación se configura los enlaces troncales a los tres switch, si se fijan en la topología al switch S1 se configura el puerto troncal hasta el Fa0/5, por que es el puerto al que se conecta al Router en modo troncal el cual va a permitir el enrutamiento entre VLAN.

Está configuración aplica a los tre switch.

S1(config)#int range fa0/1-5
S1(config-if-range)#switchport mode trunk
S1(config-if-range)# switchport trunk native vlan 99
S1(config-if-range)#no shutdown
El switch S2 y S3 solo se configura hasta el Fa0/4 y se configura
 la VLAN nativa que es la 99 y no se deja la predeterminada que es 1

Se configura las VLAN en el servidor VTP

VLAN Nombre de la VLAN
VLAN 99 Administración
VLAN 10 RyD
VLAN 20 Ingeniería
VLAN 30 Sala
S1(config)#vlan 10
S1(config-vlan)#name RyD
S1(config-vlan)#vlan 20
S1(config-vlan)#name ingenieria
S1(config-vlan)#vlan 30
S1(config-vlan)#name Sala
S1(config-vlan)#vlan 99
S1(config-vlan)#name administración
Para verificar la conf "sh vlan brief" además se hace los mismo en los demás
switch a ver si se ha extendido las vlan a los switch clientes(VTP)

Se configura la dirección IP de administración de los tres switch

S1(config)#int vlan 99
S1(config-if)#ip address 192.168.99.11 255.255.255.0
S1(config-if)#no shutdown
S1(config-if)#exit
S1(config)#ip default-gateway 192.168.99.1
Está configuración se hace en los 3 switch con su respectiva dirección IP de administración

Asignar puertos de switch a las VLAN en S2.

 S2(config)#int range fa0/5-10
S2(config-if-range)#switchport access vlan 30
S2(config-if-range)#int range fa0/11-17
S2(config-if-range)#switchport access vlan 10
S2(config-if-range)#int range fa0/18-24
S2(config-if-range)#switchport access vlan 20
S2(config-if-range)#end

Bueno eso seria en la configuración de capa 2, pero falta algo más y es la configuracion del router para que permita el enrutamiento entre VLAN.

Y es aqui donde se introduce el protocolo IEEE 802.1q también conocido como dot1q(encapsulamiento) la cual permite a multiples redes compartir de forma transparente el mismo medio físico sin problemas de interferencia entre ellas(trunking).

Lo primero es configurar las subinterfaces correspondientes para cada VLAN en el puerto Fa0/0, la configuración es la siguiente.

R1(config)#int fa0/0
R1(config-if)# no shutdown
R1(config-if)#int fa0/0.1
R1(config-subif)#encapsulation dot1q 1 /Ojo 1 es la vlan 1 que es la predeterminada
R1(config-subif)#ip address 192.168.1.1 255.255.255.0
R1(config-subif)#int fa0/0.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0
R1(config-subif)#int fa0/0.20
R1(config-subif)#encapsulation dot1q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0
R1(config-subif)#int fa0/0.30
R1(config-subif)#encapsulation dot1q 30
R1(config-subif)#ip address 192.168.30.1 255.255.255.0
R1(config-subif)#int fa0/0.99
R1(config-subif)#encapsulation dot1q 99 native (se especifica que es la 99 la vlan nativa y no la predeterminada)
R1(config-subif)#ip address 192.168.99.1 255.255.255.0

Se configura la dirección IP para el puerto del router fa0/1 y al servidor y las Pc’s con sus respectivas direcciones IP y luego se hace ping de pc a pc y el ping tiene que ser exitoso, lo que significa que hay comunicación entre vlan.

  1. enero 6, 2014 a las 11:32 am

    Buenas tardes. Creo que hay un error en la configuración del router R1. Cuando se configuran las subinterfaces, en el artículo se indica que la operación se realiza sobre los interfaces fa0/0 (0/0.10, 0/0.20, etc). Sin embargo, en la topología de la red se establece que ese interfaz es el fa0/1. Un saludo.

    • enero 8, 2014 a las 12:18 am

      Es cierto, la imagen está mal editada… Tranquilamente en el CLI se le cambia por la Fa0/1.. Saludos

  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: